Conflict with Updraft Plus

Hi, been using SAC for about 2 years. After some bad situations in the past we're doing daily backups as preventative maintenance. We changed our backup process to use Updraft Plus (paid version).

However, there's a conflict with UpdraftPlus (paid version only) that seems to be rooted in JS/JQ according to the debug instructions on UpdraftPlus:  https://updraftplus.com/do-you-have-a-javascript-or-jquery-error/

I went through all my plugins one-by-one and the problem only appears when SAC is enabled.

I saw this issue was brought up once here but doesn't seem to have a resolution: https://www.cxthemes.com/question/conflict-with-updraft-plus/

The tricky thing with troubleshooting this is the bug only appears with the paid version of Updraft plus, not the free version, and only when the "Activate included Addons" is linked (which enables automatic backups).

According to the linked page above: "When this happens, it is always the fault of the other plugin/theme – because they should not be loading JavaScript at all on UpdraftPlus’s settings page. The fact that their JavaScript is causing a conflict just makes it worse; but, they should be loading it only on their own settings page."

Can you please provide any support on this issue to help debug?

 

 

Add Comment
10 Answer(s)

Ouch.

Ok. Passing this along to developer

Sean

Answered on July 17, 2017.
Add Comment

Update please?

Answered on July 20, 2017.
Add Comment

It has been sent to development and they're checking it out. Don't have a timeline right now.

Answered on July 20, 2017.
Add Comment

What is the progress on this? The ticket is 2 weeks (14 days) old now and no status update has been provided.

Answered on July 30, 2017.
Add Comment

It's because we need to load javascript for the Admin Bar link for our plugin to work. Changing this affects all users of the plugin so we're working it out carefully. We don't have a timeline. In the meantime you'll need to deactivate one or the other plugin until we've changed how our plugin works.

Answered on August 2, 2017.
Add Comment

Hi Greg,

If you could send us logins we can see what the JS errors are to better fix them. Or else if you could send a screengrab of them in Dev Tools > Console.

 

If you'd like to send us logins please do so here: https://www.cxthemes.com/users/send-login-details/

Thanks

Sean

Answered on August 2, 2017.
Add Comment

The credentials have been sent via your link

Answered on August 3, 2017.
Add Comment

Any update yet?

 

What's the usual turnaround time for corrective action on the code?

Answered on August 11, 2017.
Add Comment

Update please?

Answered on August 14, 2017.
Add Comment

I feel like I'm being ignored.

I purchased this plugin because support was included...but I'm not receiving support.

Answered 2 days ago.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.