Shortcodes in subject do not work for new order template

Hello,

I am facing one issue with email subject. When new order is created, incoming email does not have proper subject. It says "New order ({order_number}) on MyShop ({order_date}) ".

Strange thing is that shortcodes work with other email templates, such as Order confirmation for customer. The only e-mail where this does not work is the New order template that is sent to shop owner.

Other strange thing is that we have another e-shop with I would say identical setup (plugin versions, WP version, etc.) and there it works fine.

Would it be please possible to point me to the right direction what to check and verify to make it working again?

Thanks,

Petr

Add Comment
5 Answer(s)

Have you checked the settings in WooCommerce -> Settings -> Emails -> New Order?

Can you send a screenshot of that screen.

Answered on July 9, 2018.
Add Comment

Hi Sean, thanks for getting back to me.

The settings are as follows: https://cl.ly/152g3R453U2Z/download/Image%202018-07-09%20at%205.59.28%20PM.png

Shortcodes are there, but when the email is received, they are not converted to real values.

Thank you

Petr

Answered on July 9, 2018.
Add Comment

I don't know why this would be happening. Can you switch your whole site to english and see if that changes it? I can't think of anything else right now. Does it only happen on the new order email?

Answered on July 10, 2018.
Add Comment

Yes, this happens only with the New order email template. On the other site which has identical setup it does not happen at all. Both sites are in CZ only.

Answered on July 10, 2018.
Add Comment

Sorry. We're looking into this now.

Answered on July 11, 2018.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.