Update to WooCommerce 3.6.1 breaks on line 1068

This is breaking the customer site.  There is an issue with not finding class emogrifier.

 

When will this be fixed?

 

PHP Fatal error:  Uncaught Error: Class 'Emogrifier' not found in /home/customerid/public_html/wp-content/plugins/woocommerce-email-control/ec-email-control.php:1068

Stack trace:

#0 /home/customerid/public_html/wp-content/plugins/woocommerce-email-control/ec-email-control.php(1014): WC_Email_Control->ec_style_inline_for_old_wc('<!DOCTYPE html>...')

#1 /home/customerid/public_html/wp-includes/class-wp-hook.php(286): WC_Email_Control->ec_style_inline('<!DOCTYPE html>...')

#2 /home/customerid/public_html/wp-includes/plugin.php(208): WP_Hook->apply_filters('<!DOCTYPE html>...', Array)

#3 /home/customerid/public_html/wp-content/plugins/woocommerce/includes/emails/class-wc-email.php(608): apply_filters('woocommerce_mai...', '<!DOCTYPE html>...')

#4 /home/customerid/public_html/wp-content/plugins/woocommerce/includes/emails/class-wc-email-customer-reset-password.php(114): WC_Email->send('[email protected]', 'Password Reset ...', '\r\n<!DOCTY$

#5 /home/customerid/public_html/wp-includes/class-wp-hook.php(286) in /home/customerid/public_html/wp-content/plugins/woocommerce-email-control/ec-email-control.php on line 1068

Add Comment
4 Answer(s)

Same here!

Answered on April 21, 2019.
Add Comment

I seen the upgrade, but it didn't work. If i need to upload new version of Email customizer on to my cpanel files directly, does anyone know which files keep my settings?  I don't want to lose my previous setting and templates i made with the program.  I have to download manually because its not working with upgrade feature for some reason.

Answered on April 27, 2019.
Add Comment

I saw the available update, but reading these messages I'll wait. Bad support as always. The fact that the developers read this messages and do not answer at all is a really bad behavior.

Answered on May 2, 2019.
Add Comment

Hi.

Apologies the late reply.

We have fixed this issue – please update to the latest version of our plugin – WooCommerce Email Customizer 3.27.

You can update via your wp-admin or download from CodeCanyon.

Thanks

Answered on May 10, 2019.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.